Home
Log In
Message Boards
Search our See-Doo Board
Sea-Doo Community Pictures
Sea-Doo Models
Sea-Doo Classifieds
Sea-Doo Tech Articles
Sea-Doo Tech Specs
Sea-Doo.net FAQ's
PWC Links
Need sea-doo help?
Email Us!

Perry Performance Group Parts Store


CanDoo OBD Diagnostic tool
CanDoo OBD Diagnostic tool

LOOKING FOR A PART NUMBER? Save time by using the BRP Part Catalogs Search

Sea-Doo Part Catalogs
BRP Part Catalogs

American Watercraft Association

International Jet Sports Boating Association

Personal Watercraft Industry Association



 
   Saturday, November 22, 2014  


 Author:   Topic: 97 GSI w/burnt out 5 amp MPEM fuse
 Jimmypwadd posted: 5/23/2007 1:21:00 PM   

Hugh,
Did you ever figure out what is blowing the 5 amp fuse? I am in the same situation. As soon as I hook the 4 pin connection that goes into the flywheel/ magneto cover it blows. I have the cover off and was going to pull the flywheel yesterday but couldn't find my puller. Any help would be appreciated.
Thanks,
James

 

 hugh100mph posted: 11/12/2006 7:29:49 PM   

I FOUND IT!!!!!!!!!!!!!!!!!!!!!!!!
I decided to test the wires going in to the MPEM from their source. When I worked on the wires from the coil/starter relay box, I got some funky readings. sometimes high resistance. I revisited the connection, cleaned with with electrical contact cleaner, applied some dialectric grease and BINGO. IT BLEEPED. I found the yellow/red wire going into the MPEM had backed out of the holder about 1/2 inch. Fixed that and IT STARTED! I tidyed up a few things and put it in the water and tested. Man it runs good -= of course I had rebuilt the xhaust (broken flange at the manifold - heliarced it), rebuilt the pump completly with a new wear ring and seals and bearings, put a new MPEM (used) in, cleaned the plugs - now its faster than my 96GTX - course it is still Original - only plugs have been changed - and fuel lines.
Thanks again guys and hope this helps somebody.
PS the female pins in that connection are impossible to find. Went to several electronics places and no one had them. They said everything has gone to a square type. I sistered a wire out of the box and around the connector., that fixed it. It was the red power lead! It would still light up a test light at the MPEM!

 

 hugh100mph posted: 11/11/2006 12:02:07 AM   

By the way - I worked for an auto mfr for 27 years - engineering dept. We had a "super multiple junction" that had almost 150 wires through it. We could check resistance through it with an ohm meter. Not this baby. Gonna pinch them "females" and see what happens.
 

 hugh100mph posted: 11/10/2006 11:57:47 PM   

Thanks Islander. I'll post again when I have something. I do feel it is probably a connection - resistance in one. Wish me luck! Tomorrow AM will do GP suggestion on the female connections. Wish they all worked like that!!!!!!!!!!!!!!!!!!!!!!1
 

 Islander posted: 11/10/2006 6:12:46 PM   

The 1995 XP was the last year you could easily diagnose problems wit the 717. Your plight covers most of the reasons I hate the newer mpems! Too complicated and hard to diagnose trouble. Not to mention cost! Good luck with the search!
 

 hugh100mph posted: 11/10/2006 5:54:23 PM   

Well - back to the drawing board. Torqued the flywheel, put the cover on, installed all connections -AND NO BEEP!!!!!!!!!!
When you install the lanyard, the speedo and instruments come on, but it won't beep
GP. Gonna try your suggestion on the female connectors. I took everything loose and sprayed electrical contact cleaner, then blew it out with shop air. Used new fuses, still the same. Hope the female connector tip works. Thanks.

 

 hugh100mph posted: 11/10/2006 5:52:44 PM   

Well - back to the drawing board. Torqued the flywheel, put the cover on, installed all connections -AND NO BEEP!!!!!!!!!!
When you install the lanyard, the speedo and instruments come on, but it won't beep
GP. Gonna try your suggestion on the female connectors. I took everything loose and sprayed electrical contact cleaner, then blew it out with shop air. Used new fuses, still the same. Hope the female connector tip works. Thanks.

 

 GP@PPG posted: 11/9/2006 7:40:07 PM   

So NO by-pass of fuse block for quick diagnostics huh? Reach in to ALL of the female spade terminals on ALL of your Sea-Doo's and use a small pry device to *tighten* the "Pinch" when the fuse goes into it's TWO female receptacles, especially years '95 through '01 and we still check them
GOOD FIND BUD! We have to help ole's top-kick here find his problem, few are going to have the prowess that you do, so thanks for helping others here, I REALLY need the help.


 

 hugh100mph posted: 11/9/2006 7:04:26 PM   

I FOUND IT!!!!!!!!!!!!!!!!!!!
I truly lost sleep over this thing last night. Got up this morning with a plan in mind to diagnose it.
Started by taking a 5 amp fuse (bad) cut it in half and took the plastic off. Tested the 5 and 15 amp fuses first and they had continuity. Stuck my test blade in and found 12 volts to the input of the 5 and 15 amp fuses. Put the fuses in - still no beep when the lanyard was installed. Removed the fuses again, sprayed it THOROUGHLY with WD 40. Put the fuses back in, put the lanyard back on and BEEP BEEP!!!
gLENN - I HAD PREVIOUSLY TAKEN THE FRONT COVER and flywheel off and inspected it and Ohm'd it. I even removed the VTS cover - nice and dry.
I assumed (and I know what it spells) that since the fuses had been in and out numerous times that the connection would be OK. Never again. Now they will all get a thorough cleaning - and will use some corrosion cleaner first then WD 40 and dialectric grease and anything else I can think of.
Hey - guys - thanks for all the suggestions. They all helped. Older you get - the dumber you get I guess.
Glenn - when you coming? Want a 190 MPH Suzukie to ride while you're here?

 

 GP@PPG posted: 11/9/2006 11:06:00 AM   

Hey 100MPH! What's a matter, you can't fix that thing? E-mail glen@sea-doo.net with a phone# so I can call you. Gotta be up that way in few weeks! GP

VERY suspicious of the VTS housing as well
topkick. You may have more than one failure. You need to pull the front engine cover as CDN states to see if a simple metal shard isn't causing it all.

 

 hugh100mph posted: 11/8/2006 11:05:18 PM   

Big T
Yes - I've checked out everything. Had the same thing happen to me once that you did - so check for starting with or without beeps. Won't do the self diagnostic thing either. Really stumped this time. Wish I had a 97 GSI that I could put this control unit in and see if it starts it! Like a backwards test. It dsoesn't blow any fuses though and has power to it.

 

 BigT posted: 11/8/2006 8:06:23 PM   

Hugh, this may sound stupid, but today I was out riding, shut it off 3 or 4 times, and the last time, no beeps. I thought aww hell, what now, but when I plugged it back in, again no beeps, but, the gages came up, and it started. did you happen to look at the gages when you plug it in? Just in case...... BigT
 

 hugh100mph posted: 11/8/2006 7:58:44 PM   

Have gotten the new/used MPEM and the lanyard reprogrammed by the dealer. Very reasonable!
However, still no beeps when the lanyard is installed. Have checked grounds. Solenoid is good. No fuses blown. Magneto connection makes no difference. VTS is ok - at least no water in box.
Suggestions? Help!
PS thanks again Islander.

 

 hugh100mph posted: 11/6/2006 11:25:29 AM   

Wow!!!!!!!!!! Forgot all about the lanyard needing to be programmed. Man - how stupid can I be? I think I'll see ifI can get the old lanyard from the seller of the mpem. the local dealer has a history of breaking it off in you.

Thanks Man!!!!!

 

 Islander posted: 11/6/2006 11:09:35 AM   

So did you have your lanyard programmed to the new mpem?
 

 hugh100mph posted: 11/6/2006 10:52:34 AM   

Have installed the new (used) mpem and the 5 amp fuse no longer blows, but I cannot get any signal - beeps - when I put the lanyard on. Have checkd the lanyard with an ohm meter and it functions properly. Have 12 volts to the mpem and all fuses are ok. Signal from magneto is difficult to EXACTLY acertain. It appears to be OK though and does not blow the 5 amp fuse when connected. I visually inspected everything under the flywheel and could see nothing wrong. HELP Factory shop manual is a joke when it comes to diagnosing the "no beeps" situation!
 

 hugh100mph posted: 11/2/2006 10:00:17 AM   

Further investigation showed that magneto had a bad signal (o ohms). Pulled flywheel, everything looked OK. Checked ohms with flywheel removed - no bad signal(no "0" ohms). Reinstalled flywheel (no nut). Have same good signal. THEN noticed a line of "goop" coming from the MPEM. Removed it. Goop coming out from back! Have a new used one coming today. Wish me luck.
 

 hugh100mph posted: 10/28/2006 9:55:09 AM   

Thanks Nick. Hope its not that. This all started when I went to crank the engine after an exhaust repair. It started and ran for about 5 seconds and quit. From then on it refused to give the two beeps and repeatedly burned the 5 amp fuse. Found water in the coil box/bucket and repaired all of that but could not get the 2 beeps and still burned the 5 amp fuse. Then discovered it would only do it when the magneto connection was connected. So ---- will start on that this morning.
Thanks again,
Hugh

 

 Enyawmai posted: 10/28/2006 9:54:50 AM   

on a 2000 GTi, i checked and rechecked every single connection and part. ended up being the mpem itself.

fyi, this boat's problem was pre-empted by an electirc box full of agua as well. it had a corroded 15A fuse, and i think that fuse went bad then the guy tried to boost it rather than check and change the fuse. he never admitted to it, but surrendered the repair fee fairly quickly. electronics suck to diagnose

 

 Islander posted: 10/27/2006 11:34:03 PM   

I hope it's not the case, but I'm currently rebuilding a 1997 GS that did exactly what you described. It turned out the main bearings were shot, causing the flywheel to ground out on the stator (trashed the flywheel and stator). It was easy to hear the problem though when cranking. If yours sounds bad when cranking, it probably is a similar problem.
 

 hugh100mph posted: 10/27/2006 10:34:04 PM   

Thanks Chris, thats the first thing I'll do tomorrow AM. Is this incident anything like the piece of the starter bendix gear coming off and getting between the stator and magnets on the 800's? Fixed one of those already.
 

 CDN eh posted: 10/27/2006 9:17:15 PM   

Pull the front motor cover and flywheel and check the magneto and charging coils. Something might have damaged either the wiring or the coils.

I have seen the flywheel rub through wiring because a $.02 clip that keeps the wiring out of the flywheel was not installed.

 

 hugh100mph posted: 10/27/2006 8:47:49 PM   

I have further investigated and cleaned other connections. I am left with the 5 amp fuse blowing if the Magneto connector - four pin at the top of the magneto housing- is connnected.
Even though the VTS is still connected, it will not blow the fuse - only the magneto connector.
Help please!

 

 hugh100mph posted: 10/23/2006 9:23:37 PM   

i HAVE THE SAME PROBLEM ON A FRIENDS SKI THAT i AM WORKING ON - 5 AMP BLOWING. fOUND WATER IN THE BOX WITH THE COIL. GOT IT OUT, CLEANED EVERYTHING, STILL THE SAME. WILL WATER IN THE VTS BLOW THE 5 AMP FUSE?
PS - GP - YOU'RE STILL UGLY AND YOUR BEAUTIFUL WIFE DRESSES YOU FUNNY!!!!!

 

 topkick posted: 7/27/2006 10:10:14 PM   

Well, it was working the last time it was in the water as far as I know. This is my wifes ski and she pretty much leaves the trim set at one position where it seems to work best overall. Is there a way to check the vts without the fuse working? Thanks..
 

 topkick posted: 7/27/2006 9:05:41 PM   

Well, it was working the last time it was in the water as far as I know. This is my wifes ski and she pretty much leaves the trim set at one position where it seems to work best overall. Is there a way to check the vts without the fuse working? Thanks..
 

 seadoofreak5402 posted: 7/27/2006 7:44:09 PM   

i also have a 97 stock gsi the fuse also burnt i took the vts out and figured out the vts box was full of water see the sea doo manufactures put potting compound where the wires go in to the vts box but the wire insulation doesnt have anything to prevent water going in from where the wires connect so it will fill with water if the ski gets water in it at all. does your vts work?
 

 topkick posted: 7/27/2006 7:11:23 PM   

GP@PPG, with all connections disconnected, I installed a new 5 amp fuse in the mpem. Next i connected the plug at the top of the electrical box that contains the starter solenoid, fuse does not blow. Next I connected the plug at the magneto, fuse blows. Disconnect plug at mag, replace fuse, connect 6 or 7 pin plug from vts to main harness and the fuse blows again. Is the problem in the mag, the VTS, the starting circuit? I checked all wires within these circuits throughout the loom for continuity and all appeared to be okay. Checked ground wires from battery to starter, checked battery positive cables to solenoid. Part of the difficulty in troubleshooting is not having power throughout the system due to the fuse blowing. Help???
 

 topkick posted: 7/27/2006 10:08:37 AM   

I probably need to relook the grounds, I also need to do the circuit by circuit elimination and see how that goes. Thanks for the assist, I'll let ya know how it goes.
 

 GP@PPG posted: 7/27/2006 9:25:27 AM   

Start methodically unpluging things other than the bare essentials (gauge cluster, VTS,anything of the like) ONE at a time and see if you can determine if any of the periphrials are the problem. If not, and this is considering that ALL grounds are 100% checked and re-checked, then you do need an mpem. The easiest way (no such thing)
to find out what "IT IS" is to sometimes find out what it isn't and they aren't known for having any type of high-failure rate on this model and it's electrics. Hope this helps, GP@PPG

 

 topkick posted: 7/26/2006 10:30:27 PM   

I was riding my stock '97 GSI when the engine just quit, no sounds, beeps or anything to indicate a problem. I disconnected the lanyard and reconnected it and there were no beeps. After a little bit of troubleshooting (based on the generic seadoo maintenance manual) I determined that the 5 amp fuse in the mpem was fried. I took the opportunity to remove and fully charge the battery at this point, afte reinstalling the battery I replaced the fuse in the mpem and connected the battery instantly frying the new fuse. I've checked start button and warning buzzer, I could not check the DESS due to lack of power at the MPEM, I did the press the start button 5 times and of course that didn't work. I checked the starter solenoid box in the rear of the ski, found out it was full of water and a connection (small wire on hot side of solenoid) was corroded and disconnected. I repaired this and replaced the fuse and it burned out again. I've disconnected all the weather tight connectors coming out of the aft plug in the mpem and determined the only connection that fries the fuse is from starter. I've checked the wires (positive and ground) using a continuity test and they appear to be okay. I don't want to spend $480 to troubleshoot the ski if the mpem is not the problem. I'm not sure where to go from here, maybe the mpem has an internal short. Any and all suggestions would be greatly appreciated.
 

Reply to Thread
Topic: 97 GSI w/burnt out 5 amp MPEM fuse
Subject:
User Name:  You have not logged in. You will need to type your user information here.
Password: 
Enter message below (press return after each line)


want to advertise on the largest seadoo enthusiast site on the web?.. click here

Copyright © 1998 - 2014 SEA-DOO.net All Rights Reserved

Sea-doo.net is not affiliated with BRP Inc. This is a user supported information and support site for the Sea-Doo Watercraft & Sport Boats products.

SEA-DOO®, SKI-DOO®, ROTAX®, CELEBRITY® are registered
trademarks of Bombardier Inc. and/or its affiliates. GTX is a
trademark of Castrol Limited, used under license.
© 1998 Bombardier Inc. *Trademarks and ® Registered 
Trademarks of Bombardier in the U.S. Patent and Trademark Office 
and in other countries. All rights reserved.
All posts and emails to Sea-Doo.net become the property of Sea-Doo.net.
Sea-Doo.net is not responsible for inaccurate opinions and advise posted to Sea-Doo.net.